Page 10 of 12 FirstFirst ... 8 9 10 11 12 LastLast
Results 91 to 100 of 115
  1. Collapse Details
    Re: RZR 570 'S' build - The hybrid
    #91
    Senior Member mech_head6's Avatar
    Join Date
    Mar 2009
    Location
    Milwaukee, WI
    Posts
    478
    Default


    The inlet & outlet are 2.5" OD




    Ignore the RTV, it had a bad seal so the PO did that. I've got a new seal for the cover.
    Polaris RAGER 570/1000 S Hybrid
    • Engine - 2016 RZR 1k XP
    • Transmission - RZR 1k XP
    • Chassis - 2012 RZR 570
    • Suspension -
      • Front: RZR 800S A-arms/Ranger 900 XP hubs
      • Rear: Ranger 900 XP A-arm/hubs

    https://www.minibuggy.net/forum/utv-a...ld-hybrid.html


    "The grass isn't always greener, but the sun's always shining on the other side of the clouds."
    Reply With Quote
     

  2. Collapse Details
    Re: RZR 570 'S' build - The hybrid
    #92
    Senior Member mech_head6's Avatar
    Join Date
    Mar 2009
    Location
    Milwaukee, WI
    Posts
    478
    Default
    More progress last night:

    - Secondary clutch installed
    - Clutch cover ducting assembled
    - Installed skid plate
    - Installed center console

    This is the first time the seats have been back in it since probably January.. Definitely felt good to sit in it and make braap music!



    Polaris RAGER 570/1000 S Hybrid
    • Engine - 2016 RZR 1k XP
    • Transmission - RZR 1k XP
    • Chassis - 2012 RZR 570
    • Suspension -
      • Front: RZR 800S A-arms/Ranger 900 XP hubs
      • Rear: Ranger 900 XP A-arm/hubs

    https://www.minibuggy.net/forum/utv-a...ld-hybrid.html


    "The grass isn't always greener, but the sun's always shining on the other side of the clouds."
    Reply With Quote
     

  3. Collapse Details
    Re: RZR 570 'S' build - The hybrid
    #93
    The Bob Ross of MBN Bullnerd's Avatar
    Join Date
    Jan 2006
    Location
    Cream Ridge ,NJ
    Posts
    8,894
    Default
    Ill take some measurements, thanks.

    This things gonna rip!
    "Speed is time-time is speed"-Dennis Hopper

    Quote Originally Posted by TALON View Post
    did you use a special bigfoot camera or something ,you know all blurry could be a tree stump kinda thing .
    Reply With Quote
     

  4. Collapse Details
    Re: RZR 570 'S' build - The hybrid
    #94
    Senior Member mech_head6's Avatar
    Join Date
    Mar 2009
    Location
    Milwaukee, WI
    Posts
    478
    Default
    More work on the RAGER again last night.
    - Got the front of the cage bolted in with the door frame
    - Installed the roof, nice to have this attached and not taking up space in my garage
    - Nearly finished the front clutch box intake to the bed side
    - Trial fit the filter box inlet filter, decided to order a different one. I had ordered a K&N type cone, but now ordered a "ball type" foam filter hoping it will package better and not interfere with the bed-frame mount
    - Finished the muffler mounting. Added barbs to the rubber hanger tabs to keep them engaged in the rubber hanger, finish welded the tabs to the muffler in their new bent state
    - Added 2 springs to the muffler so it is properly secured
    - Started to mount the XP1k rear muffler heat shield. This will mesh in with the rear valance for a decent rear setup I hope. Eventually I'll finish the muffler cage so it is mounted to the frame down by the A-arm pivot. That will act as the rear bumper.
    Polaris RAGER 570/1000 S Hybrid
    • Engine - 2016 RZR 1k XP
    • Transmission - RZR 1k XP
    • Chassis - 2012 RZR 570
    • Suspension -
      • Front: RZR 800S A-arms/Ranger 900 XP hubs
      • Rear: Ranger 900 XP A-arm/hubs

    https://www.minibuggy.net/forum/utv-a...ld-hybrid.html


    "The grass isn't always greener, but the sun's always shining on the other side of the clouds."
    Reply With Quote
     

  5. Collapse Details
    Re: RZR 570 'S' build - The hybrid
    #95
    Senior Member mech_head6's Avatar
    Join Date
    Mar 2009
    Location
    Milwaukee, WI
    Posts
    478
    Default
    Things are still progressing!

    Last night I finished mounting the muffler heat shield. Stock lower XP1k mounts go to the square chassis frame tubes, upper mounts get chopped up and welded to what I call the muffler cage. Turned out very solid and looking good. Like I said, will eventually finish the muffler cage down to the chassis below the muffler, but not now.

    After that, cut and fit the rear valance to fit with the muffler heat shield. Turns out they look like they were meant to be together!

    Here's a pic of a stock 570 rear valance setup, which includes the muffler guard. It is very common for them to deform and melt on the muffler.


    Here's a pic of my new setup, mid process, shouldn't be any melting, I hope.
    Polaris RAGER 570/1000 S Hybrid
    • Engine - 2016 RZR 1k XP
    • Transmission - RZR 1k XP
    • Chassis - 2012 RZR 570
    • Suspension -
      • Front: RZR 800S A-arms/Ranger 900 XP hubs
      • Rear: Ranger 900 XP A-arm/hubs

    https://www.minibuggy.net/forum/utv-a...ld-hybrid.html


    "The grass isn't always greener, but the sun's always shining on the other side of the clouds."
    Reply With Quote
     

  6. Collapse Details
    Re: RZR 570 'S' build - The hybrid
    #96
    Senior Member mech_head6's Avatar
    Join Date
    Mar 2009
    Location
    Milwaukee, WI
    Posts
    478
    Default
    Also got to spend some time exploring a few new areas in the MI UP this past weekend.

    WOW as always.





    Polaris RAGER 570/1000 S Hybrid
    • Engine - 2016 RZR 1k XP
    • Transmission - RZR 1k XP
    • Chassis - 2012 RZR 570
    • Suspension -
      • Front: RZR 800S A-arms/Ranger 900 XP hubs
      • Rear: Ranger 900 XP A-arm/hubs

    https://www.minibuggy.net/forum/utv-a...ld-hybrid.html


    "The grass isn't always greener, but the sun's always shining on the other side of the clouds."
    Reply With Quote
     

  7. Collapse Details
    Re: RZR 570 'S' build - The hybrid
    #97
    Senior Member mech_head6's Avatar
    Join Date
    Mar 2009
    Location
    Milwaukee, WI
    Posts
    478
    Default
    New ECM shows up today!! Sent the other one back to get it checked out.

    Really hoping this fixes it!
    Polaris RAGER 570/1000 S Hybrid
    • Engine - 2016 RZR 1k XP
    • Transmission - RZR 1k XP
    • Chassis - 2012 RZR 570
    • Suspension -
      • Front: RZR 800S A-arms/Ranger 900 XP hubs
      • Rear: Ranger 900 XP A-arm/hubs

    https://www.minibuggy.net/forum/utv-a...ld-hybrid.html


    "The grass isn't always greener, but the sun's always shining on the other side of the clouds."
    Reply With Quote
     

  8. Collapse Details
    Re: RZR 570 'S' build - The hybrid
    #98
    Senior Member mech_head6's Avatar
    Join Date
    Mar 2009
    Location
    Milwaukee, WI
    Posts
    478
    Default
    This weekend was a blur. I stood in my good friends wedding on Saturday, so wedding events dominated the weekend. The wedding reception was at the Harley Davidson museum, very cool. Today my wife was nursing a wicked hangover so I stayed around home.

    BUT - I had like 3 minutes on Friday before the rehearsal so I plugged in the new ECM and turned the key. Stuff happened! The fuel pump fired up, the gauge was alive, and the LED dash light came on. None of these were functional before. Turned the key and it cranked over and fired , then died .. Multiple attempts ended in the same result.


    Only other time I was able to fit in was going back to pull the check engine codes:

    520279 31 = Throttle Body Control - Adaptation Aborted
    520207 5 = All Wheel Drive Control Circuit
    520230 31 = IC CAN Communication with EPS

    The second and the third I'm not concerned with. Neither would have any impact on the car starting and running. Both are inspired by not having things hooked up currently. The front diff is disconnected (and prop shaft removed), and the power steering box is currently sitting on the shelf. The first one I believe is the issue. Tells me something is goofed in the ETC. I'm not sure yet if it is a pedal issue or a throttle body issue, will do some more figuring in the next few days.
    Polaris RAGER 570/1000 S Hybrid
    • Engine - 2016 RZR 1k XP
    • Transmission - RZR 1k XP
    • Chassis - 2012 RZR 570
    • Suspension -
      • Front: RZR 800S A-arms/Ranger 900 XP hubs
      • Rear: Ranger 900 XP A-arm/hubs

    https://www.minibuggy.net/forum/utv-a...ld-hybrid.html


    "The grass isn't always greener, but the sun's always shining on the other side of the clouds."
    Reply With Quote
     

  9. Collapse Details
    RZR 570 'S' build - The hybrid
    #99
    Senior Member mech_head6's Avatar
    Join Date
    Mar 2009
    Location
    Milwaukee, WI
    Posts
    478
    Default
    I'm in the rut now of the final build details.. I've been doing lots of tidying, tucking, and detailing. Lots of fiddling, nothing to show for it.

    I'm currently waiting for another ECM. We believe the issue on the last one was the calibration. It was calibrated for a 1000 S, not a 1000 XP. The biggest difference being the throttle body. XP1k is a dual throttle body, 1k S is a single throttle body. Hence the ECM engine code... I had previously considered running this setup, that would have been ironic..

    Another thing I had to do was add a few pins to the wire harness, I have a '14 XP1k harness. 2 things missing: the exhaust o2 sensor and the seat belt safety switch. I want to run the o2 for safety sake, and those calibrations make a little more power. I plan to run harnesses, so the seat belt switch is just to trick the ECM. It has to see 12V to not go into limp mode. Thankfully I have a spare junk harness, so I stole a few like-colored pins out of it. That was the tricky part. Inserting them into the ECM plug wasn't as bad as I thought. First, remove the piece that captures all the pins, then remove each individual small dummy pin, insert the new wire until you get a satisfactory snap. Now I've got a few wires hanging out of the ECM connector that will need to get run accordingly.

    Also finished more trimming and prepping, lots of zip-tying.. I'll be traveling to Montreal for work this week, hopefully the ECM is on the door step by the time I get back!! Hurry up brown Santa!
    Polaris RAGER 570/1000 S Hybrid
    • Engine - 2016 RZR 1k XP
    • Transmission - RZR 1k XP
    • Chassis - 2012 RZR 570
    • Suspension -
      • Front: RZR 800S A-arms/Ranger 900 XP hubs
      • Rear: Ranger 900 XP A-arm/hubs

    https://www.minibuggy.net/forum/utv-a...ld-hybrid.html


    "The grass isn't always greener, but the sun's always shining on the other side of the clouds."
    Reply With Quote
     

  10. Collapse Details
    Re: RZR 570 'S' build - The hybrid
    Senior Member mech_head6's Avatar
    Join Date
    Mar 2009
    Location
    Milwaukee, WI
    Posts
    478
    Default
    It's alive!!! Confirmed that the ECM calibration was the issue!

    The new ECM showed up yesterday, had a few quick minutes to install and try it, cranked and fired right up! Will still have to do cooling system bleed and burb, but it's ready to drive around the back yard as is.

    Hopefully I'll be able to make tracks somewhere this weekend!
    Polaris RAGER 570/1000 S Hybrid
    • Engine - 2016 RZR 1k XP
    • Transmission - RZR 1k XP
    • Chassis - 2012 RZR 570
    • Suspension -
      • Front: RZR 800S A-arms/Ranger 900 XP hubs
      • Rear: Ranger 900 XP A-arm/hubs

    https://www.minibuggy.net/forum/utv-a...ld-hybrid.html


    "The grass isn't always greener, but the sun's always shining on the other side of the clouds."
    Reply With Quote
     

Page 10 of 12 FirstFirst ... 8 9 10 11 12 LastLast

Similar Threads

  1. Twin GSXR1000 Barracuda build
    By leok in forum Barracuda
    Replies: 179
    Last Post: 09-30-2014, 06:32 PM
  2. How to build a bearing carrier
    By punchdrunk monkey in forum Driveline
    Replies: 8
    Last Post: 01-11-2011, 12:16 PM
  3. Kids Kart Build
    By Donald79 in forum Projects in Progress
    Replies: 5
    Last Post: 12-27-2010, 03:38 PM
  4. Best plans for first build?
    By Nobody077 in forum Frame
    Replies: 26
    Last Post: 09-29-2010, 04:34 AM
  5. Input Wanted for my next build.
    By TutTech in forum Projects in Progress
    Replies: 21
    Last Post: 07-05-2007, 11:07 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •