Results 1 to 8 of 8
  1. Collapse Details
    Slow return to idle. Need help
    #1
    Senior Member fns's Avatar
    Join Date
    Apr 2012
    Location
    phoenix az
    Posts
    182
    Default
    Motor: 2008 turbo hayabusa. This has been steadily getting worse and now dangerous to drive. (It did not do this for the first 2 years and I have not changed anything)
    Problem: Rev the motor up above 6k rpms and the throttle body snaps back but the motor slowly or Lazy returns back to idle. (Car Idles fine).
    Things I have tried to eliminate.
    1. vacuum leak. (I sprayed starter fluid all around the throttle body and vacuum hose with no rpm change)
    2. Pulled the intake off and inspected butterflies and they seem to closing properly.
    3. Disconnected my throttle cables and manually tested the throttle bodys and same results. (Snaps back to close and rpm's slowly go back to Idle)

    Possible issues (NEED HELP)
    1. IAC "Idle air control valve" This motor does have the stock IAC that is just capped off by the throttle bodies. (This has always been this way) Maybe it still does something in the throttle bodies??
    2. Just notice one of the injectors is leaking. Not sure how that would affect it?
    3. ???Not sure where to go next....Fuel (I run race gas 104 unleaded) Fire (New plugs and upgraded coils) Air (New air filter)???

    Thanks
    Just trying to put every ass into a comfortable seat. BsSand & Racecraft Seats
    Reply With Quote
     

  2. Collapse Details
    Re: Slow return to idle. Need help
    #2
    Senior Member
    Join Date
    Jun 2014
    Location
    Upper Peninsula, MI
    Posts
    245
    Default
    Im certainly no expert so I'd wait for some of the more knowledgeable people to chime in, but it sounds like you've checked most air related things so I'd guess it's fuel related. When you say an injector is leaking, where is it leaking at?
    Reply With Quote
     

  3. Collapse Details
    Re: Slow return to idle. Need help
    #3
    Member
    Join Date
    Mar 2018
    Location
    Central Ohio
    Posts
    60
    Default
    A Thought ...Have you checked the TPS (throttle position sensor) ? Possibly not telling the ECU to "shut down"
    Reply With Quote
     

  4. Collapse Details
    Re: Slow return to idle. Need help
    #4
    Senior Member fns's Avatar
    Join Date
    Apr 2012
    Location
    phoenix az
    Posts
    182
    Default
    The Fuel is leaking outside right at the fuel rail...(Maybe just o-ring, Or it may be leaking in the cylinder??)....I have check the TPS. I have the Power commander pcv-pti and It shows real time TPS settings.
    Just trying to put every ass into a comfortable seat. BsSand & Racecraft Seats
    Reply With Quote
     

  5. Collapse Details
    Re: Slow return to idle. Need help
    #5
    Senior Member fns's Avatar
    Join Date
    Apr 2012
    Location
    phoenix az
    Posts
    182
    Default
    Well....Replaced the o-rings on the injectors and still have the slow rpm return??? It acts like a vacuum leak. I have sprayed a a bunch of starting fluid on all the intake parts with no idle change. I also have a smoke machine for finding vacuum leaks and my system is sealed tight?? Any other suggestions?
    Just trying to put every ass into a comfortable seat. BsSand & Racecraft Seats
    Reply With Quote
     

  6. Collapse Details
    Re: Slow return to idle. Need help
    #6
    Senior Member fns's Avatar
    Join Date
    Apr 2012
    Location
    phoenix az
    Posts
    182
    Default
    Update.....I replace the o-rings on my billet clamp that holds the throttle bodies on the motor.....I think it fixed it. Just loaded it on the trailer and heading out to Glamis.
    Just trying to put every ass into a comfortable seat. BsSand & Racecraft Seats
    Reply With Quote
     

  7. Collapse Details
    Re: Slow return to idle. Need help
    #7
    Millenium Member Deranged's Avatar
    Join Date
    Sep 2008
    Location
    Allendale MI
    Posts
    2,050
    Default
    Glad it got fixed!
    Did you do a home made turbo set up for it? If so, please post pictures and component info!

    Thanks,
    Justin
    Nowhere near the desert.
    Reply With Quote
     

  8. Collapse Details
    Re: Slow return to idle. Need help
    #8
    Senior Member studio5o's Avatar
    Join Date
    Aug 2009
    Location
    Nor Cal
    Posts
    166
    Default
    Glad its fixed too...also interested in your turbo info....thanks
    Reply With Quote
     

Similar Threads

  1. Rough Idle
    By Jcooksey in forum Ridge Runner
    Replies: 8
    Last Post: 03-09-2016, 03:07 PM
  2. High idle
    By bigdav in forum Honda's Pilot & Odyssey
    Replies: 11
    Last Post: 05-09-2013, 07:47 AM
  3. slow slow build
    By swervedog19 in forum Projects in Progress
    Replies: 17
    Last Post: 05-19-2010, 06:15 PM
  4. FL250 idle way too high..
    By samsonx in forum Honda's Pilot & Odyssey
    Replies: 22
    Last Post: 10-12-2009, 03:35 AM
  5. Low idle, slow throttle response
    By Creativeness in forum Honda's Pilot & Odyssey
    Replies: 104
    Last Post: 10-05-2008, 05:34 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •