Results 1 to 8 of 8
  1. Collapse Details
    HELP NEEDED.... gy6 no spark
    #1
    Default
    Hi guys.
    Im new to the forum have a few buggies. I am at a loss as to why i have no spark on my 150cc linhai engine. I have replaced the statir cdi plug and coil. The plug fires as the key is turned off. Has anyone ever had this issuč?
    Reply With Quote
     

  2. Collapse Details
    Re: HELP NEEDED.... gy6 no spark
    #2
    Super Moderator Wheels's Avatar
    Join Date
    Feb 2009
    Location
    Baton Rouge area
    Posts
    1,908
    Default
    Welcome to the forum the rattler. If you are getting spark... Are you sure you are getting fuel?
    Reply With Quote
     

  3. Collapse Details
    Re: HELP NEEDED.... gy6 no spark
    #3
    Millenium Member Xbird's Avatar
    Join Date
    May 2013
    Location
    Easton, PA
    Posts
    1,815
    Default
    check your kill switch circuit. some also have a safety switch wired in at the brake pedal. crank with no fire at hte plug and all good components is usually a short in the kill circuit or a bad ignition switch.
    Reply With Quote
     

  4. Collapse Details
    Re: HELP NEEDED.... gy6 no spark
    #4
    Senior Member
    Join Date
    Jun 2014
    Location
    Upper Peninsula, MI
    Posts
    243
    Default
    My buggy started with a similar engine, and a similar problem with no spark. our solution was to rip it out and stuff in a sled motor in it's place But we never did figure out the no spark problem...
    Reply With Quote
     

  5. Collapse Details
    Re: HELP NEEDED.... gy6 no spark
    #5
    Default
    Thanks guys ill have a look for a kill switch circuit or brake pedal.... never even thought about a brake switch. Had a little look early this morning and found a 12v wire going to the ground pin of the cdi.that has me stuffed does not make any sense unless the previous owner tried to repair
    Reply With Quote
     

  6. Collapse Details
    Re: HELP NEEDED.... gy6 no spark
    #6
    Default
    Ok so a bit more investigating found power at tye coil when the earth not plugged into tye coil. When i plug the earth in nothing
    ... any ideas?
    Reply With Quote
     

  7. Collapse Details
    Re: HELP NEEDED.... gy6 no spark
    #7
    Default
    Anyone have any ideas?
    Reply With Quote
     

  8. Collapse Details
    Re: HELP NEEDED.... gy6 no spark
    #8
    Millenium Member Xbird's Avatar
    Join Date
    May 2013
    Location
    Easton, PA
    Posts
    1,815
    Default
    Likely a short. again, i'd take a look at your ignition switch or kill circuits. the spark you get when you key off is showing you that it's not wired properly or the coil feed is being triggered at the wrong source. the 150s should have an engine ground and chassis ground stock, always good to add direct ground from the battery to the frame and another direct to the swingarm.
    Reply With Quote
     

Similar Threads

  1. Hayabusa spark issues, please help!
    By Nsparker in forum Controls and electrical
    Replies: 1
    Last Post: 11-11-2012, 11:02 PM
  2. fl250 no spark
    By supermini in forum Honda's Pilot & Odyssey
    Replies: 4
    Last Post: 02-03-2012, 08:15 PM
  3. 05 GSXR spark issue
    By gssickels in forum Motor - Engine
    Replies: 14
    Last Post: 06-04-2010, 05:55 PM
  4. honda odyssey with no spark
    By fl250dirtslinger in forum Honda's Pilot & Odyssey
    Replies: 20
    Last Post: 10-28-2008, 08:18 PM
  5. Complete List needed for builders
    By Battleborn in forum MiniBuggy.net Lounge!
    Replies: 10
    Last Post: 01-14-2008, 03:50 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •